Aqua clear 110 will not turn on?

  • Fishy7798
  • Fishy7798's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0

Fishy7798 created the topic: Aqua clear 110 will not turn on?

The impeller simply refuses to start spinning, when I plugged it in it started working, but made a lot of weird sounds. Is it possible that activated carbon got in the filter?
Edit: I just tried hosing it out, it didn't work. :(
#411443

Please Log in or Create an account to join the conversation.

  • Posts: 4511
  • Karma: 1
  • Thank you received: 254

DRACO replied the topic: Aqua clear 110 will not turn on?

there are several factors that can make the impeller not turning:
1) yes, some foreign object may have gotten into the impeller shaft wall;
2) iron rod rubber bushing may have lost;
3) mis-aligned hub nosing.

try to shake the hub nosing... it may work...
#411444

Please Log in or Create an account to join the conversation.

  • Fishy7798
  • Fishy7798's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0

Fishy7798 replied the topic: Aqua clear 110 will not turn on?

It seems like my activated carbon is leaking into where the impeller is, could that be the cause of the problem?
It turns out that when I feel the top metal part of the impeller, I feel a small vibration, yet it doesn't move
#411447

Please Log in or Create an account to join the conversation.

Moderators: Big-KenDRACO
Time to create page: 0.128 seconds