help!

  • aaronblove
  • aaronblove's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 66
  • Thank you received: 0

aaronblove created the topic: help!

OK so my Os laid again, 14 days later. I had to order some methylene blue online because no pet stores I went to carry it. I just filled a 10 gal tank with about 8 gals of water from the parents tank and dosed it with 3/4 of a teaspoon of meth blue. I have not moved eggs yet. They've been laying for about 4 hours now. Should I pull them now or wait till in the morning? Did I use the right dose of meth blue?
#340305

Please Log in or Create an account to join the conversation.

  • Posts: 11056
  • Thank you received: 877

Rocksor replied the topic: help!

I don't think you can overdose of meth blue.

www.americanaquariumproducts.com/Aquarium_Disease.html#quarantine

1 teaspoon of a 2.303% solution per 10 gallons every other day for 10 days with water changes before each treatment. BEST USED IN A HOSPITAL TANK. Methylene blue can destroy nitrifying bacteria and plants in the display aquarium.

Another key point is that Methylene Blue can quite SAFELY be overdosed as it takes high amounts with long term exposure to be toxic,


It's best to wait until you have wigglers before pulling the eggs out, unless the parents already have fry to take care of.
#340306

Please Log in or Create an account to join the conversation.

  • aaronblove
  • aaronblove's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 66
  • Thank you received: 0

aaronblove replied the topic: help!

Last time I tried that I ended up losing most my eggs to fungus. That's y ima dose w/ mb
#340307

Please Log in or Create an account to join the conversation.

  • aaronblove
  • aaronblove's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 66
  • Thank you received: 0

aaronblove replied the topic: help!

The eggs have been hatching for over 24 hrs now. Deff the best amount I've ever hatched! The meth blue completely kept the fungus from growing but some of the fry are still attached to the slate. Strange. Guess they're just still hatching. But even after its been 24 hrs sense I noticed them hatching??
#341102

Please Log in or Create an account to join the conversation.

Moderators: Big-KenDRACO
Time to create page: 0.124 seconds