Help or advice please!!!

  • BlueMoonJay
  • BlueMoonJay's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 343
  • Thank you received: 14

BlueMoonJay created the topic: Help or advice please!!!

Alright, this problem could be one of 2 things in my new tank with my plants. When I planted them into the tank, I used Seachem Flourish tabs in my PFS every 4-6" like the bag suggested. The lighting is Marineland single bright LED single bright strip light. I just ordered Seachem Essential liquid plant pack from dfs, in hopes it will help.

Or, my 2nd assumption as to why the plants are dying could be 3 of my baby angels that are in the tank now,as well as my 6" pleco. I know the pleco is moving the sand around and exposing the roots. I have also caught him eating the sword plant I have.

Is there anything that I can do to try and save them? Otherwise, they just got $40 worth of expensive vegetation
#327979

Please Log in or Create an account to join the conversation.

  • gorgoroth
  • gorgoroth's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Evil IT Administrator
  • Posts: 1373
  • Thank you received: 80

gorgoroth replied the topic: Help or advice please!!!

use clay pots to put the plants in or put a small rock formation to cover the base of the roots around the plant. angels and pleco's aren't really diggers so your plants should be fine.
i always tend to put some rocks around the plant, if it grows it'll push the rocks away bit by bit or grow around the rocks. also put the plants deep enough into the sand.

160 gallon south american
190 gallon malawi
#327985

Please Log in or Create an account to join the conversation.

  • BlueMoonJay
  • BlueMoonJay's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 343
  • Thank you received: 14

BlueMoonJay replied the topic: Help or advice please!!!

I've noticed my pleco shifts the sand around big time. The plants were buried 2" deep. I have smaller river rock pieces that I can put around the plants, that's no issue. My biggest concern is I just came home from work and saw the pleco eating the sword plant, and now have several leaves either missing, half eaten or dead.

I wonder though, if I'm not getting enough light to them.
#328099

Please Log in or Create an account to join the conversation.

Moderators: Big-KenDRACO
Time to create page: 0.104 seconds